Yum thread.error: can’t start new thread

If you get this error (thread.error: can’t start new thread) when you are trying to update your CentOS (I got this error when I tried to install PHP), you have a two step solution to overcome this issue. This is not very common issue, and its about the memory resource problem with the VPS which is caused by Yum’s fastestmirror plugin. Here is the solution;

  1. Stop the mysql server.
  2. Start Yum again after disabling Yum’s fastestmirror plugin like the code below;
yum --disableplugin=fastestmirror update

You should now update your CentOS.

Share this Post

  • Twitter
  • Facebook
  • Digg
  • Delicious

Leave a Reply